<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Everyone Loves Easter Eggs | The AppsLab</title>

<meta name="generator" content="WordPress" />
<link rel="me" type="text/html" href="http://www.google.com/profiles/rich.manalang"/>
<link rel="me" type="text/html" href="http://www.google.com/profiles/jkuramot"/>
<link rel="stylesheet" href="http://theappslab.com/wp-content/themes/appslab-2.0/css/blueprint/screen.css" type="text/css" media="screen, projection"/>
   
<link rel="stylesheet" href="http://theappslab.com/wp-content/themes/appslab-2.0/css/blueprint/print.css" type="text/css" media="print"/> 

<!--[if IE]><link rel="stylesheet" href="http://theappslab.com/wp-content/themes/appslab-2.0/css/blueprint/ie.css" type="text/css" media="screen, projection"/><![endif]-->

<link rel="stylesheet" href="http://theappslab.com/wp-content/themes/appslab-2.0/custom.css" type="text/css" media="screen, projection" />



<link rel="alternate" type="application/rss+xml" title="The AppsLab RSS Feed" href="http://theappslab.com/feed/" />
	<link rel="pingback" href="http://theappslab.com/xmlrpc.php" />

	
<!-- All in One SEO Pack 2.3.11.1 by Michael Torbert of Semper Fi Web Design[305,356] -->
<meta name="description"  content="Over the years, I've put a fair amount of thought into the ways that game mechanics can improve software usability. I'm not alone, since now there's, a name for" />

<link rel="canonical" href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The AppsLab &raquo; Everyone Loves Easter Eggs Comments Feed" href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theappslab.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='social-logos-css'  href='http://theappslab.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://theappslab.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://theappslab.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://theappslab.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theappslab.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='http://theappslab.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theappslab.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theappslab.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Some Topics for 2013' href='http://theappslab.com/2013/01/02/some-topics-for-2013/' />
<link rel='next' title='Another Nexus 4 Review, Mine' href='http://theappslab.com/2013/01/08/another-nexus-4-review-mine/' />
<meta name="generator" content="WordPress 4.7" />
<link rel='shortlink' href='http://wp.me/p1PVUy-2Os' />
<link rel="alternate" type="application/json+oembed" href="http://theappslab.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheappslab.com%2F2013%2F01%2F03%2Feveryone-loves-easter-eggs%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theappslab.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheappslab.com%2F2013%2F01%2F03%2Feveryone-loves-easter-eggs%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Everyone Loves Easter Eggs" />
<meta property="og:url" content="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/" />
<meta property="og:description" content="Over the years, I&#8217;ve put a fair amount of thought into the ways that game mechanics can improve software usability. I&#8217;m not alone, since now there&#8217;s, a name for this process, gami…" />
<meta property="article:published_time" content="2013-01-03T19:48:26+00:00" />
<meta property="article:modified_time" content="2013-01-03T19:48:26+00:00" />
<meta property="og:site_name" content="The AppsLab" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />

  <link href='http://fonts.googleapis.com/css?family=Droid+Sans:regular,bold' rel='stylesheet' type='text/css'/>

  <script src="http://platform.twitter.com/anywhere.js?id=Dr8FIshy03Ed7r0T1Q4yYw&v=1"></script>
  <script type="text/javascript">
     twttr.anywhere(function(twitter) {
              twitter.hovercards();
     });
  </script>
</head>




<body lang="en">

  <!-- Header -->
 <div id="masthead">
 <div class="container" id="header">

   <div class="span-12" id="header-left">

     <h1><strong><a href="http://theappslab.com" id="logo"><span class="hide">The AppsLab</span></a></strong></h1>

  </div> <!-- /header-left -->


   <div class="span-12 last" id="header-right">
          <!-- START Search -->
          
<div id="search-form">	
<form method="get" id="searchform" action="http://theappslab.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form>
</div><!-- /search-form -->          <!-- END Search -->
	   <!-- Navigation -->
	   <div id="navbar">
		   <ul>
		   <li class="page_item page-item-2"><a href="http://theappslab.com/about/">About</a></li>
		   </ul>
	   </div> <!-- /navbar -->
	   <!-- End Navigation -->
   </div> <!-- /header-right -->


 </div> 
 </div><!-- /header -->
  <!-- End Header -->

	


<div class="container" id="main">

  <div class="span-18" id="content">
          <h2><a href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/" rel="bookmark">Everyone Loves Easter Eggs</a></h2>

     <p class="meta">
     <span class="byline">By Jake</span> &#149;
     <span class="timestamp">January 3rd, 2013</span> &#149;
     <span class="commentnum">
     <a href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/#respond">Leave a Comment</a>     </span>
     </p>
	
     <p>Over the years, I&#8217;ve put a fair amount of thought into the ways that game mechanics can improve software usability. I&#8217;m not alone, since now there&#8217;s, a name for this process, gamification.</p>
<p>The biggest problem designers face when attempting to create engagement through game mechanics is &#8220;doing it right,&#8221; and since each system is different, as are its users, even when you do it right for some, others hate it.</p>
<p>I&#8217;m <a href="http://theappslab.com/2011/08/08/easter-egg-features-in-mobile/">a huge fan of Easter Eggs</a>, and I&#8217;ve come to think this is the best way to sprinkle game mechanics into existing software.</p>
<p>Why?</p>
<p>First off, unexpected discovery creates surprise, e.g. <a href="http://techcrunch.com/2012/03/27/pull-to-refresh-the-patent/" target="_blank">Loren Brichter&#8217;s pull to refresh</a>, which debuted in his awesome Twitter client, Tweetie. You could use Tweetie without ever noticing this feature, but I&#8217;m guessing very few did because once it was discovered, people wanted to share it. It didn&#8217;t hurt that Tweetie was a great app, but pull to refresh became its hallmark feature.</p>
<p>This is the second reason I like Easter Eggs, people will share them because discovery feels like an accomplishment, something you want to brag about discovering and show your friends.</p>
<p>Some gestures are like this. The iPhone has always been a pick-up-and-use device, by design, so many gesture features aren&#8217;t obvious. Find a gesture-based action accidentally? Share it. For example, swipe to delete individual message in iOS Mail has existed for many releases, but you don&#8217;t need it to use the app.</p>
<p>The designer in me dislikes features with no affordances, but the player in me likes to discover new ways to do things.</p>
<p>Another great example is <a href="http://sachagreif.com/design-details-of-google-maps-for-ios/" target="_blank">shake to report feedback in Google Maps</a>. Facebook is said to have used this in their <a href="http://techcrunch.com/2012/11/24/facebook-droidfooding/" target="_blank">internal, employee-only builds of Facebook for Android</a>.</p>
<p>I love this because it taps the human emotion of frustration. Phone isn&#8217;t working right? Shake that sucker and teach it a lesson. I wonder how many people found that accidentally.</p>
<p>Most recently, <a href="http://theappslab.com/2012/12/07/turning-on-developer-options-in-android-4-2-1/">enabling the developer options in Android 4.2 is a nice Easter Egg</a>. To be fair, I didn&#8217;t find this on my own; I had to search for it. I&#8217;m not alone. The post I did on this has been the leading traffic driver recently, which tells me that a lot of people got Nexus devices for the holidays.</p>
<p>Google does a nice job by adding a message, counting the taps and then declaring that you are now an Android developer, as if it were that easy.</p>
<p>These are just a few examples, but I&#8217;d include stuff like <a href="http://www.1stwebdesigner.com/inspiration/unique-404-error-pages-inspiration/" target="_blank">custom 404 pages</a> and <a href="http://en.wikipedia.org/wiki/Konami_Code" target="_blank">Konami code extras</a> as well.</p>
<p>As with any game mechanic, you run a risk if you inject discovery into the wrong process, but adding Easter Eggs is a relatively low cost, high gain method. Of course, once you do, you can layer on more traditional mechanics like questing.</p>
<p>Find the comments.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-10816" class="share-twitter sd-button share-icon no-text" href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-10816" class="share-facebook sd-button share-icon no-text" href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-10816" class="share-google-plus-1 sd-button share-icon no-text" href="http://theappslab.com/2013/01/03/everyone-loves-easter-eggs/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
     <div id="nav-below" class="navigation">
          <div class="nav-previous"><span class="meta-nav">&laquo;</span> <a href="http://theappslab.com/2013/01/02/some-topics-for-2013/" rel="prev">Some Topics for 2013</a></div>
          <div class="nav-next"><a href="http://theappslab.com/2013/01/08/another-nexus-4-review-mine/" rel="next">Another Nexus 4 Review, Mine</a> <span class="meta-nav">&raquo;</span></div>
     </div>
      
	
     <br />

<p><p><h4>Possibly Related Posts</h4></p><ul><li><a href="http://theappslab.com/2011/02/02/amy-jo-kim-on-applying-game-mechanics-to-software/" rel="bookmark" title="2 February 2011">Amy Jo Kim on Applying Game Mechanics to Software</a></li>

<li><a href="http://theappslab.com/2012/12/07/turning-on-developer-options-in-android-4-2-1/" rel="bookmark" title="7 December 2012">Turning on Developer Options in Android 4.2.1</a></li>

<li><a href="http://theappslab.com/2011/08/08/easter-egg-features-in-mobile/" rel="bookmark" title="8 August 2011">Easter Egg Features in Mobile</a></li>

<li><a href="http://theappslab.com/2014/05/15/ok-google-wheres-my-car/" rel="bookmark" title="15 May 2014">OK Google, Where&#8217;s My Car?</a></li>

<li><a href="http://theappslab.com/2007/09/07/new-saas-features-easter-egg-or-spam-blast/" rel="bookmark" title="7 September 2007">New SaaS Features? Easter Egg or Spam Blast?</a></li>
</ul><!-- Similar Posts took 26.323 ms --></p>

<!-- LEAVE A COMMENT-->

	<div id="comments">
	
<!-- You can start editing here. -->

			<!-- If comments are open, but there are no comments. -->

	 

<h3 id="respond">Leave a Reply</h3>


<form action="http://theappslab.com/wp-comments-post.php" method="post" id="commentform">


<p><input type="text" name="author" id="author" value="" size="22" tabindex="1" />
<label for="author"><small>Name (required)</small></label></p>

<p><input type="text" name="email" id="email" value="" size="22" tabindex="2" />
<label for="email"><small>Mail (will not be published) (required)</small></label></p>

<p><input type="text" name="url" id="url" value="" size="22" tabindex="3" />
<label for="url"><small>Website</small></label></p>


<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->

<p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
<input type="hidden" name="comment_post_ID" value="10816" />
</p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2247d431e0" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="73"/></p>
</form>


        </div>
</div>


  <div class="span-6 last" id="sidebar">
  
<div class="sidebar-cat">			<div class="textwidget"><a href="http://feeds.feedburner.com/TheAppslab" title="Get our feed"><img src="http://theappslab.com/wp-content/uploads/2011/02/feedbw.png" width="53" height="53"></a>
<a href="http://twitter.com/theappslab" title="Follow us on Twitter"><img src="http://theappslab.com/wp-content/uploads/2011/02/twitterbw.png" width="53" height="53"></a>
<a href="http://www.facebook.com/theappslab/"><img src="http://theappslab.com/wp-content/uploads/2011/02/facebookbw.png" width="53" height="53"></a>
</div>
		</div><div class="sidebar-cat">			<div class="textwidget"><i>The views expressed on this blog are those of the authors and do not necessarily reflect the views of Oracle.</i></div>
		</div><div class="sidebar-cat"><h2>Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Joyce</span> on <a href="http://theappslab.com/2016/12/21/emotion-recognition-at-oracle-maker-faire/comment-page-1/#comment-3940474">Emotion Recognition at Oracle Maker Faire</a></li><li class="recentcomments"><span class="comment-author-link">Abhishek</span> on <a href="http://theappslab.com/2010/06/22/oracle-people2-iphone-app-drops/comment-page-4/#comment-3933519">Oracle People2 iPhone App Drops</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://learntyping.org' rel='external nofollow' class='url'>Doreen</a></span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3932692">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link">J</span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3932622">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link">Joyce</span> on <a href="http://theappslab.com/2016/12/08/pac-man-on-a-string/comment-page-1/#comment-3932524">Pac-Man on a String</a></li><li class="recentcomments"><span class="comment-author-link">Luca</span> on <a href="http://theappslab.com/2016/03/07/the-anki-overdrive-car-project/comment-page-1/#comment-3923459">The Anki Overdrive Car Project</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://twitter.com/jkuramot' rel='external nofollow' class='url'>Jake</a></span> on <a href="http://theappslab.com/2016/03/07/the-anki-overdrive-car-project/comment-page-1/#comment-3923074">The Anki Overdrive Car Project</a></li><li class="recentcomments"><span class="comment-author-link">Luca</span> on <a href="http://theappslab.com/2016/03/07/the-anki-overdrive-car-project/comment-page-1/#comment-3921654">The Anki Overdrive Car Project</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://learntyping.org' rel='external nofollow' class='url'>Doreen</a></span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3918838">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link">Rain</span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3918301">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://twitter.com/jkuramot' rel='external nofollow' class='url'>Jake</a></span> on <a href="http://theappslab.com/2016/03/07/the-anki-overdrive-car-project/comment-page-1/#comment-3893387">The Anki Overdrive Car Project</a></li><li class="recentcomments"><span class="comment-author-link">Eric McAllister</span> on <a href="http://theappslab.com/2016/03/07/the-anki-overdrive-car-project/comment-page-1/#comment-3890296">The Anki Overdrive Car Project</a></li><li class="recentcomments"><span class="comment-author-link">Becca</span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3883359">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://4ff.c58.myftpupload.com/2012/11/fishbowls-shipit-hackathon-event-produces-four-new-value-add-components-for-oracle-webcenter-content/' rel='external nofollow' class='url'>Fishbowl’s ShipIT Hackathon Event Produces Four, New, Value-Add Components for Oracle WebCenter Content - Fishbowl Solutions</a></span> on <a href="http://theappslab.com/2012/10/05/oracle-social-network-developer-challenge-winners/comment-page-1/#comment-3877886">Oracle Social Network Developer Challenge Winners</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://4ff.c58.myftpupload.com/2012/10/openworld-2012-recap-fishbowl-solutions-aligned-with-oracles-webcenter-strategy/' rel='external nofollow' class='url'>OpenWorld 2012 Recap - Fishbowl Solutions Aligned with Oracle’s WebCenter Strategy - Fishbowl Solutions</a></span> on <a href="http://theappslab.com/2012/10/05/oracle-social-network-developer-challenge-winners/comment-page-1/#comment-3877885">Oracle Social Network Developer Challenge Winners</a></li><li class="recentcomments"><span class="comment-author-link">Joyce</span> on <a href="http://theappslab.com/2016/10/18/my-first-oracle-openworld/comment-page-1/#comment-3865032">My First Oracle OpenWorld</a></li><li class="recentcomments"><span class="comment-author-link">Raymond R Erickson</span> on <a href="http://theappslab.com/2010/06/22/oracle-people2-iphone-app-drops/comment-page-4/#comment-3864210">Oracle People2 iPhone App Drops</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://learntyping.org' rel='external nofollow' class='url'>Doreen</a></span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3859941">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link">Lisa Tweedie</span> on <a href="http://theappslab.com/2010/12/16/is-touch-typing-an-obsolete-skill/comment-page-4/#comment-3859092">Is Touch-Typing an Obsolete Skill?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://cartania.com' rel='external nofollow' class='url'>John Cartan</a></span> on <a href="http://theappslab.com/2016/09/30/our-real-time-ambient-display-at-openworld/comment-page-1/#comment-3856766">Our Real Time Ambient Display at OpenWorld</a></li></ul></div><div class="sidebar-cat">			<div class="textwidget"><form style="border:1px solid #ccc;padding:3px;text-align:center;" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=TheAppslab', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter your email address:</p><p><input type="text" style="width:140px" name="email"/></p><input type="hidden" value="TheAppslab" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Subscribe" /><p>Delivered by <a href="https://feedburner.google.com" target="_blank">FeedBurner</a></p></form></div>
		</div><div class="sidebar-cat">			<div class="textwidget"><p><a href="http://feeds.feedburner.com/TheAppslab"><img src="http://feeds.feedburner.com/~fc/TheAppslab?bg=000000&amp;fg=FFFFFF&amp;anim=0" height="26" width="88" style="border:0" alt="" /></a></p></div>
		</div><div class="sidebar-cat"><h2>Archives</h2>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://theappslab.com/2016/12/'> December 2016 &nbsp;(3)</option>
	<option value='http://theappslab.com/2016/11/'> November 2016 &nbsp;(2)</option>
	<option value='http://theappslab.com/2016/10/'> October 2016 &nbsp;(6)</option>
	<option value='http://theappslab.com/2016/09/'> September 2016 &nbsp;(5)</option>
	<option value='http://theappslab.com/2016/08/'> August 2016 &nbsp;(1)</option>
	<option value='http://theappslab.com/2016/07/'> July 2016 &nbsp;(8)</option>
	<option value='http://theappslab.com/2016/06/'> June 2016 &nbsp;(5)</option>
	<option value='http://theappslab.com/2016/05/'> May 2016 &nbsp;(10)</option>
	<option value='http://theappslab.com/2016/04/'> April 2016 &nbsp;(2)</option>
	<option value='http://theappslab.com/2016/03/'> March 2016 &nbsp;(16)</option>
	<option value='http://theappslab.com/2016/02/'> February 2016 &nbsp;(5)</option>
	<option value='http://theappslab.com/2016/01/'> January 2016 &nbsp;(11)</option>
	<option value='http://theappslab.com/2015/11/'> November 2015 &nbsp;(3)</option>
	<option value='http://theappslab.com/2015/10/'> October 2015 &nbsp;(9)</option>
	<option value='http://theappslab.com/2015/09/'> September 2015 &nbsp;(9)</option>
	<option value='http://theappslab.com/2015/08/'> August 2015 &nbsp;(17)</option>
	<option value='http://theappslab.com/2015/07/'> July 2015 &nbsp;(9)</option>
	<option value='http://theappslab.com/2015/06/'> June 2015 &nbsp;(9)</option>
	<option value='http://theappslab.com/2015/05/'> May 2015 &nbsp;(14)</option>
	<option value='http://theappslab.com/2015/04/'> April 2015 &nbsp;(8)</option>
	<option value='http://theappslab.com/2015/03/'> March 2015 &nbsp;(6)</option>
	<option value='http://theappslab.com/2015/02/'> February 2015 &nbsp;(2)</option>
	<option value='http://theappslab.com/2015/01/'> January 2015 &nbsp;(11)</option>
	<option value='http://theappslab.com/2014/12/'> December 2014 &nbsp;(5)</option>
	<option value='http://theappslab.com/2014/11/'> November 2014 &nbsp;(8)</option>
	<option value='http://theappslab.com/2014/10/'> October 2014 &nbsp;(7)</option>
	<option value='http://theappslab.com/2014/09/'> September 2014 &nbsp;(8)</option>
	<option value='http://theappslab.com/2014/08/'> August 2014 &nbsp;(7)</option>
	<option value='http://theappslab.com/2014/07/'> July 2014 &nbsp;(4)</option>
	<option value='http://theappslab.com/2014/06/'> June 2014 &nbsp;(5)</option>
	<option value='http://theappslab.com/2014/05/'> May 2014 &nbsp;(15)</option>
	<option value='http://theappslab.com/2014/04/'> April 2014 &nbsp;(2)</option>
	<option value='http://theappslab.com/2014/03/'> March 2014 &nbsp;(4)</option>
	<option value='http://theappslab.com/2014/02/'> February 2014 &nbsp;(5)</option>
	<option value='http://theappslab.com/2014/01/'> January 2014 &nbsp;(3)</option>
	<option value='http://theappslab.com/2013/12/'> December 2013 &nbsp;(3)</option>
	<option value='http://theappslab.com/2013/11/'> November 2013 &nbsp;(5)</option>
	<option value='http://theappslab.com/2013/10/'> October 2013 &nbsp;(7)</option>
	<option value='http://theappslab.com/2013/09/'> September 2013 &nbsp;(7)</option>
	<option value='http://theappslab.com/2013/08/'> August 2013 &nbsp;(4)</option>
	<option value='http://theappslab.com/2013/07/'> July 2013 &nbsp;(6)</option>
	<option value='http://theappslab.com/2013/06/'> June 2013 &nbsp;(8)</option>
	<option value='http://theappslab.com/2013/05/'> May 2013 &nbsp;(10)</option>
	<option value='http://theappslab.com/2013/04/'> April 2013 &nbsp;(13)</option>
	<option value='http://theappslab.com/2013/03/'> March 2013 &nbsp;(5)</option>
	<option value='http://theappslab.com/2013/02/'> February 2013 &nbsp;(8)</option>
	<option value='http://theappslab.com/2013/01/'> January 2013 &nbsp;(9)</option>
	<option value='http://theappslab.com/2012/12/'> December 2012 &nbsp;(11)</option>
	<option value='http://theappslab.com/2012/11/'> November 2012 &nbsp;(11)</option>
	<option value='http://theappslab.com/2012/10/'> October 2012 &nbsp;(14)</option>
	<option value='http://theappslab.com/2012/09/'> September 2012 &nbsp;(13)</option>
	<option value='http://theappslab.com/2012/08/'> August 2012 &nbsp;(21)</option>
	<option value='http://theappslab.com/2012/07/'> July 2012 &nbsp;(22)</option>
	<option value='http://theappslab.com/2012/06/'> June 2012 &nbsp;(11)</option>
	<option value='http://theappslab.com/2012/05/'> May 2012 &nbsp;(9)</option>
	<option value='http://theappslab.com/2012/04/'> April 2012 &nbsp;(8)</option>
	<option value='http://theappslab.com/2012/03/'> March 2012 &nbsp;(8)</option>
	<option value='http://theappslab.com/2012/02/'> February 2012 &nbsp;(13)</option>
	<option value='http://theappslab.com/2012/01/'> January 2012 &nbsp;(15)</option>
	<option value='http://theappslab.com/2011/12/'> December 2011 &nbsp;(14)</option>
	<option value='http://theappslab.com/2011/11/'> November 2011 &nbsp;(15)</option>
	<option value='http://theappslab.com/2011/10/'> October 2011 &nbsp;(20)</option>
	<option value='http://theappslab.com/2011/09/'> September 2011 &nbsp;(28)</option>
	<option value='http://theappslab.com/2011/08/'> August 2011 &nbsp;(28)</option>
	<option value='http://theappslab.com/2011/07/'> July 2011 &nbsp;(16)</option>
	<option value='http://theappslab.com/2011/06/'> June 2011 &nbsp;(19)</option>
	<option value='http://theappslab.com/2011/05/'> May 2011 &nbsp;(27)</option>
	<option value='http://theappslab.com/2011/04/'> April 2011 &nbsp;(22)</option>
	<option value='http://theappslab.com/2011/03/'> March 2011 &nbsp;(33)</option>
	<option value='http://theappslab.com/2011/02/'> February 2011 &nbsp;(44)</option>
	<option value='http://theappslab.com/2011/01/'> January 2011 &nbsp;(35)</option>
	<option value='http://theappslab.com/2010/12/'> December 2010 &nbsp;(32)</option>
	<option value='http://theappslab.com/2010/11/'> November 2010 &nbsp;(42)</option>
	<option value='http://theappslab.com/2010/10/'> October 2010 &nbsp;(40)</option>
	<option value='http://theappslab.com/2010/09/'> September 2010 &nbsp;(29)</option>
	<option value='http://theappslab.com/2010/08/'> August 2010 &nbsp;(30)</option>
	<option value='http://theappslab.com/2010/07/'> July 2010 &nbsp;(38)</option>
	<option value='http://theappslab.com/2010/06/'> June 2010 &nbsp;(34)</option>
	<option value='http://theappslab.com/2010/05/'> May 2010 &nbsp;(19)</option>
	<option value='http://theappslab.com/2010/04/'> April 2010 &nbsp;(14)</option>
	<option value='http://theappslab.com/2010/03/'> March 2010 &nbsp;(19)</option>
	<option value='http://theappslab.com/2010/02/'> February 2010 &nbsp;(17)</option>
	<option value='http://theappslab.com/2010/01/'> January 2010 &nbsp;(20)</option>
	<option value='http://theappslab.com/2009/12/'> December 2009 &nbsp;(22)</option>
	<option value='http://theappslab.com/2009/11/'> November 2009 &nbsp;(18)</option>
	<option value='http://theappslab.com/2009/10/'> October 2009 &nbsp;(17)</option>
	<option value='http://theappslab.com/2009/09/'> September 2009 &nbsp;(17)</option>
	<option value='http://theappslab.com/2009/08/'> August 2009 &nbsp;(21)</option>
	<option value='http://theappslab.com/2009/07/'> July 2009 &nbsp;(23)</option>
	<option value='http://theappslab.com/2009/06/'> June 2009 &nbsp;(21)</option>
	<option value='http://theappslab.com/2009/05/'> May 2009 &nbsp;(20)</option>
	<option value='http://theappslab.com/2009/04/'> April 2009 &nbsp;(21)</option>
	<option value='http://theappslab.com/2009/03/'> March 2009 &nbsp;(25)</option>
	<option value='http://theappslab.com/2009/02/'> February 2009 &nbsp;(24)</option>
	<option value='http://theappslab.com/2009/01/'> January 2009 &nbsp;(25)</option>
	<option value='http://theappslab.com/2008/12/'> December 2008 &nbsp;(29)</option>
	<option value='http://theappslab.com/2008/11/'> November 2008 &nbsp;(30)</option>
	<option value='http://theappslab.com/2008/10/'> October 2008 &nbsp;(29)</option>
	<option value='http://theappslab.com/2008/09/'> September 2008 &nbsp;(30)</option>
	<option value='http://theappslab.com/2008/08/'> August 2008 &nbsp;(27)</option>
	<option value='http://theappslab.com/2008/07/'> July 2008 &nbsp;(37)</option>
	<option value='http://theappslab.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://theappslab.com/2008/05/'> May 2008 &nbsp;(24)</option>
	<option value='http://theappslab.com/2008/04/'> April 2008 &nbsp;(26)</option>
	<option value='http://theappslab.com/2008/03/'> March 2008 &nbsp;(22)</option>
	<option value='http://theappslab.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://theappslab.com/2008/01/'> January 2008 &nbsp;(27)</option>
	<option value='http://theappslab.com/2007/12/'> December 2007 &nbsp;(23)</option>
	<option value='http://theappslab.com/2007/11/'> November 2007 &nbsp;(37)</option>
	<option value='http://theappslab.com/2007/10/'> October 2007 &nbsp;(36)</option>
	<option value='http://theappslab.com/2007/09/'> September 2007 &nbsp;(68)</option>
	<option value='http://theappslab.com/2007/08/'> August 2007 &nbsp;(44)</option>
	<option value='http://theappslab.com/2007/07/'> July 2007 &nbsp;(60)</option>
	<option value='http://theappslab.com/2007/06/'> June 2007 &nbsp;(33)</option>
	<option value='http://theappslab.com/2007/05/'> May 2007 &nbsp;(15)</option>
	<option value='http://theappslab.com/2007/04/'> April 2007 &nbsp;(4)</option>
	<option value='http://theappslab.com/2007/03/'> March 2007 &nbsp;(3)</option>

		</select>
		</div>
</div> <!-- /sidebar-->



		


</div>



<!-- The main column ends  -->

 <div class="container" id="footer">

<div class="span-24 small center " id="footer-copyright">
<!--  <span><a title="Legal Notices" href="http://www.oracle.com/html/copyright.html">Legal Notices</a> &#149; <a title="Terms of Use" href="http://www.oracle.com/html/terms.html">Terms of Use</a> &#149; <a title="Your Privacy Rights" href="http://www.oracle.com/html/privacy.html">Your Privacy Rights</a></span><br/>
-->

&copy;2016 The AppsLab
  </div><!-- /footer-copyright-->

 </div><!-- /footer -->


	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/theappslab.com\/2013\/01\/03\/everyone-loves-easter-eggs\/":10816};
	</script>
<script type='text/javascript' src='http://theappslab.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://theappslab.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201651'></script>
<script type='text/javascript' src='http://theappslab.com/wp-includes/js/wp-embed.min.js?ver=4.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theappslab.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.4.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='http://stats.wp.com/e-201651.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'27153678',post:'10816',tz:'-8',srv:'theappslab.com'} ]);
	_stq.push([ 'clickTrackerInit', '27153678', '10816' ]);
</script>

<style>
.dsq-combo-box {
  -moz-box-shadow: 0 3px 7px #999;
  -webkit-box-shadow: 0 3px 7px #999;
  -moz-border-radius-topright:10px;
  -moz-border-radius-bottomright:10px;
  -moz-border-radius-bottomleft:10px;
  -webkit-border-top-right-radius:10px;
  -webkit-border-bottom-right-radius:10px;
  -webkit-border-bottom-left-radius:10px;
}
#dsq-combo-logo { display:none !important;}
#dsq-combo-tabs li {
  padding:5px 8px !important;
  -moz-border-radius-topleft:10px;
  -moz-border-radius-topright:10px;
  -webkit-border-top-left-radius:10px;
  -webkit-border-top-right-radius:10px;
}
#dsq-combo-tabs li.dsq-active {
  -moz-box-shadow: 0 -2px 3px #ccc;
  -webkit-box-shadow: 0 -2px 3px #ccc;
}
.dsq-comment-header {
  -moz-box-shadow: 0 0 5px #999;
  -moz-border-radius-bottomleft:5px !important;
  -moz-border-radius-bottomright:5px !important;
}
.dsq-trackback-url {
  border:1px solid #ccc;
  font-size:13pt;
  width:613px;
  padding:3px;
  color:#999;
}
</style>
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try{ 
var pageTracker = _gat._getTracker("UA-15584579-1");
pageTracker._trackPageview();
} catch(err) {} 
</script>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "UA-76412-4";
urchinTracker();
</script>
</body>
</html>


